You can use this Twitter Component with Sage CRM 7.2 (all patch levels), 7.3 GA, 7.3 SP1, and 7.3 SP2.