Summary:

Exchange 365 integration is not synchronising due to timezone issues.

Symptoms:

A variation of the following errors are appearing in the scrm logs:

ERROR [pool-2-thread-1]: 27-may-2014 16:13:53.208 Cannot find windows time zone for CRM timezone: +00:00
ERROR [pool-2-thread-1]: 27-may-2014 16:13:53.252 Cannot find windows time zone for CRM timezone: +11:00_2

Cause:

This is due to an error in the way the translations are read for the timezones.

Resolution:

First you need to find what these timezones are, so if you go into Administration -> Customisation -> Translations and type the time in the error message (eg +11:00_2) into the Caption Code box and click search.  

Description

The only translation we need to look at is 'TimezoneDeltaUTC' so take that note of that name.

Click on that link for the UTC caption code.

To fix this problem copy the translation from the one being used (in this case the spanish translation) and remove any accents (change ó to o and í to i etc.)

Description

Now go to the start search bar and type in regedit and click on the regedit.exe that comes up. You will then want to find the translation in the following location: HKEY_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> Windows NT -> CurrentVersion -> Time Zones.

You will then want to match the 'Display' field in the registry so that it is the same as the new US Translation for this timezone, as follows: 

Description

This process should be repeated for each timezone error that can be seen in the scrm logs.

NOTE: please take note of each translation you change for when this gets fixed as you may need to change them back to the original.

Status:

This issue has been addressed and fixed in Sage CRM 7.2f which is due for release at the end of September 2014