Summary:

When installing the the Exchange Oulook Plugin the following error message is displayed:

Description 

Cause:

The issue is that the user is missing a security certificate and thus not allowing the outlook plugin to install correctly.

Resolution:

1. Uninstall the plugin.
2. Download the Thawte Root Certificates (http://www.thawte.com/roots/)
There will be an option to download a root package.
3. Once the Certificates are installed, re-run the Outlook Plugin Installer as normal.