Summary:

A permissions error may be displayed when attempting to view an ASP page created using the COM API. This is likely to be caused by a permissions issue on the anonymous user.

Symptoms:

The following error message will be displayed when you attempt to view the ASP page:

Server.CreateObject Access Error
/CRM/CustomPages/sagecrmnolang.js
The call to the Server.CreateObject failed while checking permissions. Access denied to this object

For some regions, the error message will reference accpaccrmnolang.js.

Cause:

The issue may be caused by permission for the anonymous user, or settings on the application pool.

You should check the Anonymous Authentication settings in the Authentication menu for the virtual directory in inetmgr. This may be set to a specific user (e.g. the local IUSR) or the application pool identity. If the application pool identity is selected, you should check the Identity properties for the application pool to see which user account is being used.

If a domain anonymous user (IUSR) has been created, and is being used for either the virtual directory or application pool, they should be added to IIS_IUSRS (or IIS_WPG) user group on the server.

An additional check should be made to confirm which application pool is actually being used; by default, CRM will use a specific application pool set up by the installer; it will be named <CRM instance> App Pool. If a different application pool is being used, it should be determined whether there is a specific reason for this - if not, then you can generally create your own application pool for CRM.