Summary:

A user navigates to Administration -> System -> License Key Details and clicks on the option to Manually Register the License key for this install (shown below).

Description 

Symptoms:

When the user enters all the required information on the Sage CRM Product Registration page and clicks "Submit" the following error message is displayed:

Description


Cause:

The cause of this issue was that the server name in the Sage CRM database did not match the actual CRM server name (Hostname). 

Resolution:

To check the actual CRM server name (Hostname) open a command prompt and type: hostname

To check the server name in the database run the following query:
Select Parm_Value FROM Custom_SysParams where Parm_Name = 'ServerNames'
(Note this Parm_Value should end with a semi-colon e.g. CRMServer123; )

After comparing these, the server name in the database was diiferent.
To resolve this, update the Parm_Value to the correct server name.

Then perform an iisreset and you will be able to Manually Register the License Key for Sage CRM.