Summary:

A user with a security profile that only allows them to create opportunities goes to Main Menu -> New.
Instead of the new opportunity screen being displayed, the following error message is displayed:

Description 

Cause:

The cause of this was an entry in the ActionSecurity table.

Resolution / Work around:

The workaround for this issue is to run the following query in the database:

update ActionSecurity set AcSe_Deleted = 1 where acse_action = 1192

Then perform an iisreset and the issue should be resolved

Status:

This is an issue in Sage CRM patch 7.2d but it is not an issue in patch 7.2e.
The recommneded resolution is to upgrade to 7.2e