Summary:

Navigate to Administration -> E-mail and Documents -> E-mail Configuration and set the below fields to the following:

Allow send using Outlook: Yes
Outbound E-mails should be filed by: E-mail Manager
Enter a Mail Manager Server filing address
Change the Mail Manager Server filing address prefix from &bcc= to &cc=

Now save you changes and navigate to a company record.
Select New -> E-mail and select the option to "send using outlook"

Symptoms:

Note when the email opens in Outlook the bcc field contains the filing email address but the cc field should be populated as we have instructed CRM to do this.

Status:

This issue has been resolved in Sage CRM 7.3 GA.