Summary:

The default sort order on the Product Families page may prevent all product families from being visible.

Symptoms:

The issue affects customers who have more than 10 product families added under Administration -> Data Management -> Products -> Product families. When paging between the first and second pages, several of the same product families may be visible on both pages.

Cause:

The issue is caused by a different sort order being applied to the grid on the first and second pages.

An example SQL statement from the list on the first page is as follows:

SELECT * FROM ( select * , ROW_NUMBER() over(ORDER BY  prfa_name, PrFa_ProductFamilyID) AS rowranking  from vProductFamily  WITH (NOLOCK)  WHERE COALESCE(prfa_deleted, 0) = 0  ) as A  WHERE rowranking > 0 and rowranking < 11

The SQL used on the second and subsequent pages is different:

SELECT * FROM ( select * , ROW_NUMBER() over(ORDER BY  prfa_intid, PrFa_ProductFamilyID) AS rowranking  from vProductFamily  WITH (NOLOCK)  WHERE COALESCE(prfa_deleted, 0) = 0  ) as A  WHERE rowranking > 10 and rowranking < 21

Resolution:

The issue can be worked around by setting a default sort order on the prfa_name field on ProductFamilyGrid. Setting a default sort order on alternative fields should work just as well.

ProductFamilyGrid 

Status:

This issue has been resolved in Sage CRM 7.3 and later.