Summary:

After upgrading from Sage CRM 7.1 to Sage CRM 7.2 and loging in to Sage CRM for the first time, the screen appears to have not loaded correctly and none of the links on the page work.

Description 


Cause:

The case of this was an incorrect value kept in one of the Custom_Sysparams.

If you run the following query on the database:

select *from Custom_SysParams where Parm_Name like '%NonSystemClientSideScriptFiles%'

You will see that in the Parm_Value for this Custom_SysParm there is a js file, this field should be a NULL value.

Description 
Resolution:

To resolve this issue, run the follwing query:

update Custom_SysParams set parm_value=NULL where parm_name like 'NonSystemClientSideScriptFiles'

Then perform an iisreset and log back into Sage CRM. The UI should be dispalyed as expected.

More information:

WARNING: The techniques or examples contained in this email are for illustrative purposes only, and have not been tested in a production environment. The techniques or examples used are not necessarily supported features of SAGE CRM, and may not have been previously tested or implemented on a production environment. Before attempting to implement any of these techniques or examples on a production environment, they should be tested thoroughly, as use of these techniques may cause unexpected behaviour. SAGE can accept no responsibility for any issues arising from the use of these techniques. Please ensure that you back up your database and application fully before implementing any changes of this nature.