Summary:

An issue may occur when running exports from Sage CRM where the default heap memory allocations for the JRE have been altered.

Symptoms:

The following error is logged to the localhost.log in \CRM\tomcat\logs\:

Jun 26, 2014 3:14:08 PM org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet [dispatch] in context with path [/crmj] threw exception [Handler processing failed; nested exception is java.lang.OutOfMemoryError: Java heap space] with root cause
java.lang.OutOfMemoryError: Java heap space

Cause:

The error may be caused by a manual amendment being made to the JvmMs, JvmMx or JvmSS memory allocations in the JRE's memory settings.

Resolution:

The memory allocations can be set in the registry, in HKLM\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0\<CRM_INSTANCE>Tomcat7\Parameters\Java.
The default values are as follows:

JvmMs    0x00000040 (64)
JvmMx    0x00000400 (1024)
JvmSs    0x00000800 (2048)

Once these values have been amended, the Tomcat service should be restarted.