Summary:

An issue may occur when a user clicks on a report category and then immediately clicks on the log out button. This can cause a problem displaying reports on the UI for all users of the system until a metadata refresh is done.

Symptoms:

An Access Violation error will be seen in the logs and when a user goes to view the reports in a report category they are not visible through the UI even though the information still exists on the database.

Cause:

This is caused by the reports views for all reports in the report category being loaded into memory when a user clicks on the report category. As this process requires details about the user session, if the user session is ended prior to the action completing, an access violation is thrown and the reports metadata is in an incomplete state until a metadata refresh is done.

Workaround:

Instruct users not to log out of CRM immediately after clicking on the report category. Rather they should wait for the screen to load.

Status:

This issue has been fixed in 7.1n