Summary:

This issue is related to translations on workflow rules.

Symptoms:

The text that you see on a workflow rule is taken from a translation so you can translate the rule names into different languages.
When you create a workflow rule, it creates the translation - it uses the text you enter in as the CODE for the tran
slation AND it puts that text in as the translation as well.

If you edit a workflow rule, when you change the name, you are not actually changing the translation, you are just changing the CODE of the translation. So it still appears incorrect.

Cause:

1. create 2 custom entities with workflow
2. create some workflow rule for 1 of them - for example "approve"
3. create workflow rule for entity 2 like "approve me" and save it
4. rename "approve me" to "approve", it should remain as "approve me" in UI but in db it is "approve"

Resolution:

If you want to actually change the translation you have to go to: Administration -> Customisation -> Translations and find the translation for that rule by searching with Caption Family = 'WorkflowRules' and the Caption Code is your workflow rule name - when you change the translations there, then you will see the new rule names.

Status:

Development are aware of this difficulty around workflow rule translations and there may be enhancements in the future