Summary:

An error may occur when attempting to set up an Exchange integration. Those setting up an integration should be careful to ensure that they enter in the correct EWS endpoint, and not the link to the EWS WSDL definition file.

Symptoms:

The following error may be logged in the ewaresystem.log on settign up a new integration:

ERROR: checkExchangeUserEmail
 CODE: 0
 URL : http://CRM-SERVER/sdata/sagecrmExchangeSyncEngine/crmExchange/-/$service/checkExchangeWebSiteAvailability?url_ews=https%3A%2F%2Fexchange-server%2Fews%2FServices.wsdl&user_ews=crmuser&password_ews=%26ABCDEFGHIJ&domain_ews=MYDOMAIN&crmuser=Admin
 MSG : <CheckExchangeResponse><errorMessage>com.sage.scrm.syncengine.exchange.ews.service.error.SageExchangeServiceException: javax.xml.ws.WebServiceException: Could not send Message.</errorMessage><httpStatus>405</httpStatus></CheckExchangeResponse>


Cause:

The issue was cuased by entering in the wrong URL for the EWS endpoint. The correct URL would norlammy be in the following format:

https:/exchange-server.panoply-tech.com/EWS/Exchange.asmx

A URL in the following format was entered instead:

https://exchange-server.panoply-tech.com/EWS/Services.wsdl

When testing the endpoint using a browser, you are redirected by Exchange to the second URL once you have been authenticated. This URL should not be used in the integration - the correct endpoint is located at the first URL.


Resolution:

The issue can be resolved by changing the URL used in CRM for the EWS endpoint.