Summary:

A metadata issue exists within the Case_OpenedBy field in a standard Sage CRM install. This issue can be resolved via a SQL script.

Symptoms:

When Case_OpenedBy is added to a screen (such as CaseDetailBox), it may not be displayed correctly.

Case_OpenedBy error 
The field will display, but some components (such as the maynifying glass) may not operate as expected.

Cause:

This is caused by an issue wit hthe metadata for the Case_OpenedBy field on the Custom_Edits table.

Resolution:

Running the following SQL, then carrying out a metadata refresh will resolve the issue:

update custom_edits
set ColP_EntrySize = 5, ColP_LookupWidth = null
where ColP_ColName = N'Case_OpenedBy'

Status:

This issue has been raised as a bug to the development team, and has been resolved in the Sage CRM 7.3c (August 2015) patch.