Summary:

If you experience issues with the dashboard in CRM it is recommended that you run a quick schema check to ensure the sdata feed is working correctly. This can be done with the following:

http://localhost/sdata/<install-name>j/sagecrm/-/$schema

However while running this schema check you may get a HTTP 500.19 error.
Generally IIS and Internet Explorer may only provide simple generic error messages so to ensure you get detailed errors you can enable them in IIS and IE.
Try the following guide to enable these: https://community.sagecrm.com/partner_community/b/hints_tips_and_tricks/archive/2010/08/19/the-error-is-in-the-details-making-sense-of-http-500-errors.aspx

Now when you get the detailed error you may see the following:

HTTP 500.19 error


Symptoms:

HTTP 500.19 error when running the sdata schema check and the dashboards do not work.

Cause:

This is most often due to a missing line in the applicationHost.config file.

Resolution:

Add in the missing line "<section name="webFarms" overrideModeDefault="Deny" allowDefinition="AppHostOnly" />" to the applicationHost.config file.
Go to C:/Windows/System32/inetsrv/config and open the applicationHost.config file.
Do a quick search for 'webFarms' to see if the line is there. If not add in the line to the following location as you see it in our example file:

webFarms line

After you add in the line you should save the file and then perform an iisreset.

More information:

In some instances it may also be necessary to re-enable the Application Request Routing inside of IIS if it has been disabled.