Summary:

An error may appear in the Tomcat localhost.log specifying that it is unable to load a resource. Depending on the CRM version, this error may refer to an issue loading a bean with names metaDataDao, currencyList or some other resource.

The root cause of the error as given in the logs will be similar to the following:

Property 'dataSource' threw exception; nested exception is org.springframework.jdbc.CannotGetJdbcConnectionException: Could not get JDBC Connection


Cause:

This issue can be caused by a customer using a SQL Server instance of ther than the default instance (MSSQLSERVER) that is not specified correctly in Sage CRM's db.properties or jdbc.properties.

Specifying the instance on a different line in the jdbc.properties resolves the issue. This issue most typically occurs on SQL Server Express installs.

Resolution:

Modifications can be made to the db.properties or the jdbc.properties as follows:

Original:

jdbc.url=jdbc:log4jdbc:jtds:sqlserver://servername:1433/CRM;instance=instancename

New:

jdbc.url=jdbc:log4jdbc:jtds:sqlserver://servername:1433/CRM
jdbc.instance=instancename