After installing CRM you may notice that none of the tomcat features work. You get errors while either running the Interactive Dashboard, exporting files to Excel, running sdata queries etc.

If you perform a trace with Fiddler you will notice 404 errors when you try to access the dashboards. A response similar to the following is returned by the server when you access a tomcat feature (eg: when running the sdata schema check):

 Sdata 404 error

Note that the Handler says 'StaticFile'. This indicates that the URL rewriter is not working correctly. You can verify this, and whether the CRMj webapp is working at all by navigating to:


You should receive a 'Hello World' response. If this is the case you should try performing the following steps:

  1. Check that the Application Request Routing module is installed correctly, you can run: appcmd.exe list modules "ApplicationRequestRouting" from the command prompt once you are in the directory C:\Windows\System32\inetsrv. You can open a 32 bit command prompt window also to check if it is installed there. If the module is not installed you can download it from Microsoft. In some cases it may be necessary to have both the 64bit and 32bit versions of the module installed.

  2. It may be necessary to repair or reinstall the IIS URL Rewriter 2 module. To repair or uninstall it go to Control Panel -> Add or Remove Programs. You can download a copy of this module from Microsoft also.

  3. You must also ensure that the Proxy is enabled for the Application Request Routing module in the IIS Manager. In the IIS Manager choose your server-> Application Request Routing-> "Server Proxy Settings..."

    IIS ARR proxy enabled