Summary:

Our North American OPCo has given a fantastic workaround for below issue which I am sharing in this KB Article as well.

Body of email reply from support.js create a blank message reply instead of prepending a message " Your mail has been logged Thank you Panoply Support".

Symptoms:

When look into the .eml file in \CRM\Services\CustomPages\Scripts\RougeMail\   as plain text,  the message is within the embedded MIME type encoding.  But if open .eml file using Outlook or other mail client,  the body of the message is blank. 
This issue is discovered in 7.3 SP3 versions, however it may be reproducible in other versions of CRM.


Workaround:

MIME encoding in CRM program core eWare.dll are currently under reparation by the CRM Developer. 
This issue will be fixed in 2017 R3 version of Sage CRM.

 

Method #1: Edit Support.js

  1. Navigate to \Sage\CRM\Services\CustomPages\Scripts\
  2. Edit the support.js using a text editor.  (ie NotePad++)
  3. Go to Line 213, or search "eMail.Clear();"
  4. Remove the comment marker "//"  in front of "eMail.Clear();"
  5. Save the edited support.js
  6. Restart CRM Email Manager service and try Track a Case process again.

Method #2: Use Exchange Disclaimer to Prepend Email

  1. Obtain an unique email mailbox dedicated for Track a Case operation.
    (ie AutoReply@mydomain.com )
  2. Setup CRM Email Manager Option to use this unique mailbox.
  3. Go to Exchange management console, and follow setup below :
  • Select Condition :  From [ the unique email ]
  • Select Action :  Prepend disclaimer text and fallback to action if unable to apply.
  • In Specify disclaimer text, you can use HTML code for reply message.
  • After this setup, every email sent out by AutoReply@mydomain.com will have :
  • Case Reference # in the subject line provided by eWare.dll
  • Case Body appended with message from Exchange transport rule. 

 Status:

The issue is now escalated for fix in CRM 2017 R3.