Summary:

Outlook Lite Plugin for Exchange Error after installing SP2

Issue:

After upgrading to CRM SP2, install Outlook Plugin. Everytime user login to CRM gets prompted with message: 

"A New Version of the CRM Outlook plug-in is available. Click Ok to install." 

The version format in ExchangeOutlookVersion is different than the OutlookPluginVersion 

Classic uses commas (,) and Exchange uses periods (.) or commas (,)

Cause:

In the database, Custom_SysParams needs to be updated to use 7.3.0.2 for parm_name ExchangeOutlookPluginVersion. 

When Installed Lite outlook plugin, IE add-on (IeExchangeProxy.ocx) will compare version value of the Lite Outlook Plugin with the version value on SysParam tables in the CRM database.

Resolution:

1. Run SQL Script below in CRM Database : 

    update custom_sysparams set parm_value='7.3.0.2' where parm_name='ExchangeOutlookPluginVersion' 

2. Do a metadata refresh for all in Administration > System > Metadata Refresh.