Version: 7.2a
Language: English
Area: Exchange Integration

Steps to Reproduce:

1. Set up an Exchange impersonated user for an Exchange integration. Make sure that the Exchange impersonated user's primary SMTP address does not match username@domain, e.g. make it

2. Add the Exchange web service URL, Exchange server username and domain as normal in Administration -> E-mail and Documents -> Exchange Server integration.
3. Attempt to save the integration.

Actual result (please include text of any error message):

Error when creating connection to the Exchange server. If you enable CXF logging, you'll see the following come back from Exchange:

<m:ResolveNamesResponseMessage ResponseClass="Error">
<m:MessageText>No results were found.</m:MessageText>

Expected result:

You should be able to set up the integration.

More info:

The method we use to call ResolveNames changed slightly in early patches of v7.2. This issue was resolved in the 7.2d patch.


UnresolvedEntry will only work using the above if you're passing the username or primary SMTP address. The following request fragment is used in most versions of Sage CRM:


This would resolve secondary SMTP addresses, as well as the username and primary SMTP address.


Create an SMTP address for the account, so that it's in the format user@domain. Make it the primary SMTP address for that account.