Summary:

An error may appear when setting up the Exchange integration - CRM cannot connect to the synch engine.

Symptoms:

The following error is displayed in the exchangesynch.log:

ERROR: 06-Jun-2013 11:56:27.525 url: http://SERVER2/sdata/crmj/crmExchange/-/tasks/$syncSource?trackingId=ef22cb8e-0c27-4f3f-8cd2-c1fe3b50505c&count=100, error: com.sage.scrm.core.httpconsumer.error.SageHttpConsumerException: java.net.UnknownHostException: server, action: ESTABLISHING_CONNECTION_CRM_ENDPOINT

The eWare DLL is able to connect to Server2, as seen in the following entries in the ewaresystem.log:

Jun 6 2013 11:56:21.613 1152 9684 5 doEndpointGet URL: http://SERVER2/sdata/crmExchangeSyncEngine/crmExchange/-/$service/start
Jun 6 2013 11:56:21.753 1152 9684 5 doEndpointGet URL: http://SERVER2/sdata/crmExchangeSyncEngine/crmExchange/-/$service/synchroniseNow
Jun 6 2013 11:56:22.112 1152 9684 5 doEndpointGet URL: http://SERVER2/sdata/crmExchangeSyncEngine/crmExchange/-/$service/start
Jun 6 2013 11:56:22.596 1152 9684 5 doEndpointGet URL: http://SERVER2/sdata/crmExchangeSyncEngine/crmExchange/-/$service/synchroniseNow
Jun 6 2013 11:56:23.079 1152 9684 5 doEndpointGet URL: http://SERVER2/sdata/crmExchangeSyncEngine/crmExchange/-/$service/status

Resolution:

The issue was with an old server name (SERVER) being present in the ServerNames entry in the CustomSysparams table. Replacing this with the real server name resolved the issue. If this value is updated in Managemeent Studio, then a metadata refresh will be required to update the value in CRM.