Summary:

Modifying Sage CRM database settings causes Tomcat to lose SQL connection.

Symptoms:

If the database name is changed, Tomcat services stop for that install.

Cause:

This is happening because the format of the database is showing up incorrectly in the jdbc.properties file. If the database name is incorrect, a connection will not be established between the Sage CRM webapps and the SQL Server database.

 

Workaround:

Open file called jdbc.properties in folder C:\Program Files\Sage\CRM\CRM71F\tomcat\webapps\crm71fj\WEB-INF (if the name of your installation is CRM71F)

Check the line jdbc.url and modify it from this setting:

jdbc.url=jdbc:log4jdbc:jtds:sqlserver://[SERVER]:[PORT]/[CRM DATABASE];instance=[SQL SERVER INSTANCE]

TO

jdbc.url=jdbc:log4jdbc:jtds:sqlserver://[SERVER]\[SQL SERVER INSTANCE]:[PORT]/[CRM DATABASE]

[SERVER] = Database server hostname
[SQL SERVER INSTANCE] = Database server instance name, if not the default instance
[PORT] = Database server TCP/IP connection port
[CRM DATABASE] = Name of the Sage CRM database