Summary:

When the notifications are viewed at the top of the page on any page other than MyCRM, the dropdown scrollbar for 'snooze for' gets hidden behind the CRM top ribbon.

Description

As you can see the "15 minutes" option is hiden under the top ribbon.

Status:

This issue is with development and will be fixed in a future version of Sage CRM

More information:

This is not reproduceable in Google Chrome