Summary:

If you need to change the default port for CRM on IIS to anything other than port 80 you may encounter an issue when setting up Exchange integration.

The following error will appear on screen:

"CRM is attemping to establish a connection with the Sync Engine. Please wait...

The Exchange Server connection could not be saved as CRM was unable to connect to the Sync Engine. Please Refer to the Exchange Server Integration chapter of the System Administration Guide for information on possible causes of this Sync Engine connection failure."

Resolution:

To resolve this issue change the option "Use Default Sync Engine Location" to No. This will give you a text box to enter a new "Sync Engine Location". In this field add the port number to the end of the server name seperated by a colon(:).

e.g.

http://SERVER:8080/sdata/crmExchangeSyncEngine/crmExchange/-/