Summary:

Removing the Java Runtime Environment installer from the Sage CRM installer may result in an issue installing the product.

Symptoms:

The following issue will be displayed on running the installer.

The following software is required but has not been detected: Java Runtime Environment

Setup cannot continue.

Cause:

The JRE had been removed from the \Sage\CRM\Utils\EN\JRE\32 folder on the CRM install media. The missing file is labelled jre7u17.zip.

Resolution:

Replacing the file in this directory resolves the issue. Please note that this is a different file to the jre7u17_64.zip file in the \Sage\CRM\Utils\EN\JRE\64 directory.

This issue stemmed from a misunderstanding regarding CRM's JRE. On install, the CRM installer unpacks its own copy of the 32-bit Java 7 JRE into the \CRM\Services\JRE directory. This is always the 32-bit copy of the JRE - the 64-bit version is not used in this release. This JRE is needed even if another copy of the Java Runtime Engine is already installed on the server.