Summary:

A number of additional steps are required when installing Sage CRM on a Windows Small Business Server 2011 server.

Symptoms:

Failure to follow these steps may result in 'HTTP Error 500 - Internal Server Error' or "HTTP Error 503 - Service unavailable" error messages being displayed when launching Sage CRM.

Resolution:

The resolution to this issue is described in page 2-6 of the Sage CRM Installation and Upgrade Guide (CRM Installations on a 64-Bit Server - Troubleshooting Windows Small Business Server 2011):

  1. Stop IIS
  2. Remove Dynamic compression from the server roles for IIS by running the following statement on a command line:

    %windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpCompression /-[name='xpress']
  3. Change the following lines in your application Host file (applicationhost.config) located in c:\windows\system32\inetsrv\config

    Line 1:

    <filter name="Exchange OWA Cookie Authentication ISAPI Filter" path="C:\Exchange\ClientAccess\owa\auth\owaauth.dll" enabled="true" />

    to:

    <filter name="Exchange OWA Cookie Authentication ISAPI Filter" path="C:\Exchange\ClientAccess\owa\auth\owaauth.dll" enabled="true" preCondition="bitness64" />

    Line 2:

    <filter name="Exchange ActiveSync ISAPI Filter" path="C:\Exchange\ClientAccess\sync\bin\AirFilter.dll" enabled="true" />

    to:

    <filter name="Exchange ActiveSync ISAPI Filter" path="C:\Exchange\ClientAccess\sync\bin\AirFilter.dll" enabled="true" preCondition="bitness64" />

    Line 3:

    <add name="exppw" image="C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\auth\exppw.dll" />

    to:

    <add name="exppw" image="C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\auth\exppw.dll" preCondition="bitness64" />

    Line 4:

    <add name="kerbauth" image="C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll" />

    to:

    <add name="kerbauth" image="C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll" preCondition="bitness64" />

  4. Restart IIS

On  completing the above, retest by navigating to the Sage CRM login page.