Summary:

An issue may arise whereby multiple features may cease working after HTTPS is enabled manually on the CRM web server. These features may include:

  • Document exports
  • Imports
  • Exchange integration

The interactive dashboards will likely continue to work.

 

Symptoms:

On attempting to export a document, the following error is displayed in the ewaresystem.log:

Mar 7 2014 16:14:40.939 2272  3288  5     doEndpointPost URL: https://localhost/sdata/crmj/$service/createExcelReport?type=CSV&root=C%3A%5CSage%5CCRM%5CCRM%5CLibrary%5C&inputfile=C%3A%5CSage%5CCRM%5CCRM%5CLibrary%5CTemporary+Saved+Search.csv&SID=123456789
Mar 7 2014 16:14:40.955 2272  3288  5     doEndpointPost time-taken: 15ms. HTTP status code: -1
Mar 7 2014 16:14:40.971 2272  3288  1     ERROR generating excel file. Message - The connection with the server was terminated abnormally .

 

Cause:

As can be seen in the the above log sample, a HTTP request being sent via localhost to the CRMJ webapp was failing. Examining the HTTP bindings in the Internet Information Services Manager (inetmgr) may show the following: 

IIS bindings

Bindings can be edited in inetmgr by right-clicking on the website on which CRM is hosted (usually the Default Web Site), and selecting Edit Bindings.

In the above screenshot, a binding on port 443 (the HTTPS port) is present for the server's IP address on the local network, but not for localhost. Localhost will usuallly resolve to 127.0.0.1 - this can be tested easily on the server using the ping command. While localhost can be made to resolve to other addresses, this is not usually the case.

 

Resolution:

For this example, localhost was resolving to 127.0.0.1. Adding a binding on port 443 for 127.0.0.1 resolved the issue.