Summary:

Create a Task in CRM and assign this task to a Team and to a User.
Remove the User information from this task and only let a Team be attached to this task.

Symptoms:

Then this task disappears from User's My CRM Calendar.
But this task also disappears from Team CRM Calendar.

Workaround:

The only workaround is to assign a default user to every tasks when they are created to avoid this.
Go into Administration -> Customisation -> Comm_Link and in Fields tab, select field User (cmli_comm_userid). Change the default settings from ‘No Default’.

Resolution:

This issue is reolved in Sage CRM version 7.2.