Summary:

It is impossible to send E-Marketing campaigns from Sage CRM, using a Swiftpage account. No emails are sent out. They are queued.

Symptoms:

Emarketing log file [Date]spnighttask.log from folder C:\Program Files \Sage\CRM\[CRM Install Name]\Logs\Emarketing Integration is showing this error message “java.lang.IllegalStateException: Target host must not be null, or set in parameters”

Check if HTTP GET request is interpreted correctly by Swiftpage.
This other warning may be included in log file [Date]spsyncdefault.log “DefaultRequestDirector.execute Connection can be kept alive indefinitely”

Solution:

1-Open the file syncengine.properties located in folder C:\Program Files \Sage\CRM\[CRM Install Name]\tomcat\webapps\[CRM Install Name]SPSyncEngine\WEB-INF.
2-Check url setting configuration for tomcat service at line line syncengine.configurationurl=. 
Example: syncengine.configurationurl=http://localhost:[Sage CRM Tomcat Port number]/[CRM Install Name]j


3-Update this url setting configuration accordingly.
4-Restart Tomcat Service using services.msc
5-Check SwiftPage Sync Engine log files to ensure no errors.
6-Open Sage CRM and re-send email from an Emarketing Campaign.