Summary:

An issue was reported where an access violation occurred when exporting a report to Excel. The installation of Sage CRM was using IIS auto login

Cause:

The error was occurring as a result of a configuration error. When using IIS autologin, only Windows authentication should be enabled on the CRM virtual directory. On this site, both anonymous and windows authentication were enabled.

This meant that CRM was unable to export to file as the windows user (now CRM user & non-administrator) had no write permissions (only read & execute) for the CRM install virtual directory.

Resolution:

The issue was resolved by disabling anonymous access in the security/authentication section for the CRM virtual directory. The following steps can be used to amend this setting:

1. In CRM all users must be set up so that their domain user name matches their logon ID.
2. In CRM, go to Administration -> Users -> User Configuration and set Use IIS Auto Login To Yes. Next, specify the NetBIOS domain name in the Default Domain for IIS login field.
3. In IIS manager (Start -> Run -> inetmgr), go to the virtual directory security screen for the CRM install and complete the following:

  • a. Disable anonymous access.
  • b. Enable Integrated Windows Authentication

4. Restart IIS