Summary:

During the creation of e-mail templates in Sage CRM, some fields may not be available in the 'Choose Field to insert into the E-mail list' drop down list. It depends on the value of  the 'For entity:' field.

Symptoms:

How do you insert a field which is not available in the drop down list?

Workaround / Resolution:

Firstly you need to determine the name of the field's column name.
1)  Log in Sage CRM, click on Administration -> Customization -> Translations.
2)  Enable the Inline Translation Mode.
(Doing so will add an asterisk to all the fields)
3)  Browse to the Sage CRM screen where the field that needs to be added to the e-mail template is located.
4)  Locate the field and click the asterisk next to the field. A translation window is displayed.
5)  Make a note of the value in the Caption Code field (this value is the field name).
NOTE - Return to the Translations screen and de-select the Inline Translation Mode option.

Second step is to insert this Field Name to the E-mail Template:
6)  Log in Sage CRM, click on Administration -> E-mail and Documents -> E-mail Templates. Click New or click on an existing e-mail template where the field will be added.
7)  Type the field name in between hash value (#) in the subject or body of the e-mail. For example, #user_mobile#.
8)  Repeat the steps above as needed. Once finished, click Save.

Note: See KB Article 372-13130 regarding fields and entity relationship.