Summary:

If you select a New Wave Activity with the activity type set to "Outbound Call", the outbound call screens do not display.

Cause:

This was caused by the Outbound Translation being changed.

Resolution:

Navigate to Administration -> Customisation -> Translations.

Search for the following:

Caption Family: WaIt_type
Caption Code:   Outbound.

Select this and change the caption code to “OutBound” instead of “Outbound”.
The issue here is that it needs a capital B has it had being changed to a small b.