The Size of the report is too Big – Error when exporting report to Excel/CSV

Hints, Tips and Tricks

Technical Hints Tips and Tricks that cover customization and development using Sage CRM. API usage and coding are covered.

The Size of the report is too Big – Error when exporting report to Excel/CSV

  • Comments 1
  • Likes

We recently had a few cases where customers reported the error message "The size of the report is too big, use the filter criteria to reduce the size of the report." when they ran a report and exported it to Excel/CSV.  

When they run the same report as an HTML report to show on their screen, the report runs without any issue. This confirms that the report size is not massive and may only have a few hundred lines with not many columns in the report.


There are few administrative settings that play a role in the conversion process.  Let me explain these now.  

Under Administration > Email and Documents > Documents & Reports Configuration 



When a user gets the specific error that we are discussing in this article you should check the “Desktop Size Limitation (KB):” value. This value is in KB and is the size limit of the report for desktop clients. If the issue is for a user running report from desktop this is where you should look first. However, if the issue for the client is when running reports from mobile client then its “PocketPC Size Limitation (KB):” which should be examined and changed accordingly if needed.

The export to Excel/CSV function needs to convert the result from report to XML before converting it to Excel/CSV. The limitation in above 2 parameters is for the XML output for the file conversion and not the actual Excel/CSV file or the HTML output of the result set.

If the users regularly need to run reports which could exceed this limit “Desktop Size Limitation (KB):” this can be increased to 61440 KB (that is 60 MB). But this value should not exceed 122880 KB (that is 120 MB). For the mobile user “PocketPC Size Limitation (KB):” do not increase this value equivalent to a desktop size limit. As this will consume all the bandwidth. It is best to avoid running massive reports from mobile clients.

On Sage CRM 7.3 SP2 or later once the value is changed there is no need to restart Tomcat or IIS to resolve this error on the screen. If there are further issues please check ewareSystem.log file.

On a live system, you should not set “Reports Admin override:” to Yes if “Desktop Size Limitation (KB):” is already set to 61440 KB or higher. This will make sure admin user cannot override the XML output limit and slow down live system for others.

Changing values for parameters like “Reports query timeout:”, “Reports build timeout:” and “Report generator maximum memory (MB):” will not resolve this issue. In fact, changing them could lead to other errors but will just suppress this issue. For example, the issue in this article when Report generator maximum memory is set very high. Details on each of these parameters are included in System Administration Guide under Document and Report Setting section for more details.