Mail Chimp Integration - invalid API key or List ID

This question has suggested answer(s)

When i am attempting to complete the Mail Chimp integration with Sage CRM, i receive an error message that the API key or list ID is invalid. I am copying the keys directly from my Mail Chimp account, did any one else experience this issue? 

Does it have to do with my mail chimp account being free? I emailed mail chimp tech support, i am not sure if this is CRM error or Mail Chimp error. Any help is greatly appreciated thank you.

All Replies
  • Julian

    I like free.  And the MailChimp integration will work very happily with a free MailChimp account.  Have you previously connected to another list?

  • Hi Jeff,

    I tried 3 different API keys (generated when i was logged into my account as instructed) and 2 different list IDs in every combination possible. I have tried from different web browsers, and different servers on my network.

    I contacted Mail Chimp and they ran a trace while i submitted the info and they said they were not able to see any errors on their end as to why the integration wasn't working.

  • You will need to log a case.

  • Hi Julian, Apologies if this is a daft check, but does your Sage CRM environment have internet connectivity? It obviously runs a validation over the internet back to

  • Turned out to be we had tomcat issues, had to resolve tom cat first, then once the tom cat issues were resolved, we were able to save the mail chimp API key data and the integration works fine now.

  • Hi Julian,

    I have a similar issue. For me the mailChimp API was already validated but has now  disappeared.

    What was your problem with Tomcat and how did you resolve it?

  • Please I would also like to know I have the same is currently

  • The logging should give you more information

  • Thanks Jeff will check this, also the the key need to be input on the actual sage application server? or can it be a client PC?

  • It doesn't matter where you enter the details so longs as it is done through the Sage CRM Administrator screens.  The settings are then stored in the custom_sysparams table (I think) and then it is the application server (Tomcat webapp) that makes the connection.

  • If it helps anyone, I had the same error (Invalid API Key) and in my case, the problem was an IIS configuration issue.

    Localhost was not binded for ports 80 and 443.