MailChimp notification "Merge Max Limit Exceeded"

This question is not answered

I came across this problem with a customer who had just set up MailChimp and couldn't upload any people from a group.  I have replicated the issue where you create a new MailChimp Account link as usual adding the API and list ID which linked fine. You then try to upload a group to the list and you then get the following notification within CRM

"Merge Max Limit Exceeded"

I have found that if you use the default list that is created for you when creating the new MailChimp account then you get the message and no people or imported into the list, even if it's only one person in the group results. 

If you create a new MailChimp List and then use this new one it all works as it should.

Hopefully if anyone else gets the same issue then it will be a quick fix for you.

All Replies
  • Thanks for sharing although when I have created MailChimp accounts recently I didn't get a default list that created any issues for me.


  • Hi Jeff i'm not sure if this is just a recent thing as this is the first customer that has had issues. I'm not sure if this is relevant but looking back at some of the old MailChimp accounts I created they didn't have a list automatically created when first logging in.

    The customers account was created Monday and my test account created yesterday and both had the same problem, but easy to sort out when you know how :-)  

  • Thanks for this.  A great tip.


  • Hmmm, fun.  I just ran into this on 2017R3, linking to a list that's been in existence since October 2015.  This is probably the first time Synchronizing a Group/Segment since the upgrade to 2017R3 (from 7.3SP2).

    The mailchimp.log shows:

    ERROR [taskExecutorNotChecked-1]: 15-Nov-2017 11:20:44.207 Mailchimp Error code 400 - Merge Max Limit Exceeded (You have exceeded the maximum number of 30 merge fields for this list.)

    Unfortunately, my Group only displays 7 fields (8 from the SQL query, including pers_personID).

  • I think I found it.  In Mailchimp, <target List> -> Settings -> List fields and *|MERGE|* tags

    The listed fields either need to be minimal or nonexistent (as is on a newly created list), or match the list from here:  help.sagecrm.com/.../MC_CampaignMergeFields.htm

    In either case, AFTER a successful synchronization, the Merge Fields will reflect the above list, which at 30 fields is the maximum that Mailchimp will allow.

    In my case, I had several customized fields on the List that needed to be removed.  Once done, it now matches the synched fields on the above list.

    I'm guessing that the change happened around 7.3SP3 -- I'm reasonably certain that in previous versions only First Name, Last Name, Email, and Lead Description were synced.

  • Hi kiou thanks for the info, but  I and the customer just had a bog standard group with only 7 fields in it and the same group worked for the new list created which contained  Opt out of E-marketing communications and Phone Full Number which are not on the list.

    Glad you got yours sorted and I will remember to tell people to keep the results list to a minimum.

  • I actually had the same issue in 2018 R2.

    1) I just setup a brand new 2018 R2 Demo Server

    2) Setup a NEW Mailchimp Account

    3) Deleted the default MailChimp List

    3) Created a NEW Mailchimp List (GDPR)

    3) Create a new static group in SageCRM (4 columns) based on vconsentedperson called "Mailchimp Demo"

    4) Tried to "Send to Mailchimp"

    5) Got the error  "Merge Max Limit Exceeded" in notification

    I was able to get it to work by:

    1) Creating a NEW MailChimp List

    2) Change ile ListID in the Admin section of SageCRM

    2) Removing all Columns in the MailChimp List

    3) From SageCRM, "Send to Mailchimp"

  • I had the same problem with Sage CRM 2017R3. I'd get the message that "Merge Max Limit Exeeded" - My way around it was to create a list without using the GDPR list, just a regular list and it seemed to do the trick.

    Has anyone had this problem? Is it because GDPR list aren't compatible with version 2017R3 (this version doesn't have the consent tabs)...

    Thank you.

    Annie

  • Within the last 12 months MailChimp have changed the defaults when a new list is created.  Previously a MailChimp list when created had no merge fields configured which meant that when the CRM integration was configured the integration was able to populate the 30 custom merge fields as required.

    However the MailChimp list now seems to be configured with the following merge fields by default (even without the "Enable GDPR fields" option available)

    FNAME

    LNAME

    ADDRESS

    PHONE

    As explained above in the article help.sagecrm.com/.../MC_CampaignMergeFields.htm CRM does not expect these default merge fields to be there.

    The easy solution is to create a new MailChimp list, go to Settings -> List fields and *|MERGE|* tags and then remove all of the merge tags (except for *|EMAIL|* or *|MERGE0|*  which cannot be removed).  When CRM then sends a group over to MailChimp the integration will add in all the required merge fields and everything will work as expected.