Multi Select Fields in Sage CRM 2018 R3

This question has suggested answer(s)

After we did our upgrade to Sage CRM 2018 R3, all the multi-select fields are showing a selection height of 1line rather than the 5 the fields are configured for.

Why, and how do I fix it? 

Here is an example.

All Replies
  • Same issue for us.  Anybody resolve this yet?

  • Have you cleared the cache?

    Has the HTML been rendered correctly?

    E.g, as a

    select class="EDIT" size="10" name="comp_multiselect" id="comp_multiselect" multiple=""


  • Where do I find this?  Is this at the SQL Server database level or something I can do from the Administration area in CRM?

  • That little snippet was from HTML.

    I right moused clicked on the field and 'inspected the element'.  This should give an idea whether the 'height' is correctly set and arriving in the screen as correct HTML and if it is but is still displaying wrongly it will then give a hint that something is then changing the properties of the field in the browser.


  • Here is what it says for the field "Type of Industry"

  • Darlene

    The SPAN tags are used within the page to mark a section of the HTML that can then be easily identified and have formatting information applied to it.  The bit that you have highlighted in the SPAN responsible for the field caption.

    The actual HTML field will be in the span with the id "_datacomp_indtype".  You'll need to expand that bit of the HTML to get to the field

    <select class="EDIT" size="10" name="comp_indtype" id="comp_indtype" multiple="">


  • Do you have integration with Sage300? There was a css hotfix issued that corrected some style issues.

  • Yes, we are integrated to Sage300.  Thank you, do you know which hotfix that was?

  • I think many of us are experiencing this issue. I also have the problem and I am integrating with 300.

    Is there a fix for this yet?

  • Solution

    I just took a quick look at this and noticed that the size is set in HTML and the height is set in CSS. The Height is overriding the size, so it will work perfectly if you comment this out. Here is a pretty low level instruction to fix it:

    1. Go open the ergonomic.css file. The name/location of your sage folder may differ but it should be something like: C:\Program Files (x86)\Sage\CRM\CRM\WWWRoot\Themes
    2. Comment out the height line in the ".VIEWBOXCAPTION .EDIT" section.
    3. Delete all browser cookies.

    Update

    I put this as I think it's related and may be an issue for other people searching this problem.

    A common mistake would be trying to change the height of a multi-select field through the screen settings, and altering the "Height" value of the field. Instead, it should be done through the "Fields" tab by clicking on the relevant field name and setting the "Selection Height" value.

      

  • Haza! Worked for me. You are brilliant, Gabe!