Sage CRM Integration between Sage 300 2019 and Sage CRM 2018 R3

This question has suggested answer(s)

Hi

Im having an issue Synchronising tables in CRM.  When I choose to Synchronise I get:

Error Code: Unauthorized, Error Message: Sage 300 WebApi Authentication error from invalid credentials.

I have set the CRM user up with a security group that has access to Sage 300 Web API in Sage 300.  I have also changed the web.config files so admin has access to the WebApi and tried using it with the ADMIN user and getting the same issue.  Does anyone have any other ideas?

Thanks

All Replies
  • Hi Steve,

    Here are few tantrums may help you:

    1.  Metadata refresh

    2.  Make sure you have portal setup in Sage 300

    3. Try putting sage 300 user password in upper case from the CRM interface.

    4. Go to IIS -> Sites -> Select Your Sage CRM directory -> Open Authentication -> Enable Windows Authentication

       Restart IIS may be required.

    5. If not given, you also have to give each Accpac security group to Web API as shown in the screen below.

    6. If not defined in the SAge300 …\Online\Web and …\Online\WebApi folders you will find web.config files. These files have a new element specifically for the ADMIN’s use in the Web API. The element “AllowWebApiAccessForAdmin” by default is false and must be set to true for the ADMIN user to be able to use the Web API. For a normal user, you would simply grant access to the “Sage 300 Web API” security group for the module’s endpoint in the Web API that you want to access (i.e. AP, AR, GL, etc.). But for the ADMIN user who is not bound by security groups, the element in the web.config files must be set to true. And, following the setting of this element to true, simply re-start IIS for access.

    Let us know if any of this works for you.

    Cheers !

    Sharad

  • Thanks Sharad.  I had done all the above, or at least I thought I had.  It looks like it was a password case issue which I was aware of but obviously didn't check properly.  I must have had enough by Friday afternoon last week!  Thanks for your help.