Sage CRM 2018 R3 Mac

This question is not answered

Hello!

I'm aware Sage CRM isn't supported by Mac/Safari but I was wondering if anyone had any advice about the below?

We have someone that is using MacOS (Safari Browser) to use CRM which hasn't caused any problems in CRM itself but they're having an issue carrying out a data upload from their desktop. When importing, it's failing due to required fields been blank and I've been sent the import file, I'm noticing that CRM is importing it with blank rows between each record. 

This doesn't display the blank rows on his PC, but when I've got the error log on CRM and when I've being sent the import file, these blank rows between each valid row seems to be causing the problem. We've tried saving the Excel file as numerous different formats (I originally thought it may just be CSV so we did try others) with the same result. Is there any recommendations to see if we can get this to import correctly?

I've suggested to try Chrome but when we open CRM on chrome, the login screen is just constantly flickering and refreshing so you're not even able to login. I'll be suggesting to download and try installing Firefox to attempt that but is there any further suggestions for this? As if chrome works, we'd be able to use that as a workaround.

This is how it looks from the user PC (Mac)

This is how the import file looks when I receive it (Windows 10) and when I get the 'error log' from CRM:

Any advice appreciated!

Kind Regards,

Jamie

All Replies
  • Jamie

    I don't know about the blank rows.  Except since this is a CSV file it may be down to the file encoding and possible misinterpretation of CR or LF type information.

    As for the 'blinking' CRM logon screen I think this is likely to be down to a browser extension.

    See:  chrome://extensions/

    You may need to disable extensions like 'AdBlock' or 'Adobe Acrobat'.


  • Thank you for the reply, Jeff.

    We've managed to try it on Firefox and Chrome and it's still failing out due to the blank rows unfortunately. Happens on both .xlsx and different .csv files. I figure this is more to his environment/excel as opposed to CRM but I was wondering if you had any suggestions if it's down to encoding and possible misinterpretation that we could try?

  • Have you made sure that the CSV files that you use are UTF8 encoded?


  • Hi Jeff,

    Yes, when saving the file we're ensuring it's UTF-8 encoded and experiencing the same problem unfortunately.