eWare error messages [SetIdentityColumn failed]

  • Hello all. Recently I developed a custom ASP to insert some data on a new entity. To accomplish this I just made an ASP from another one already working. Unfortunately the new ASP does not work, and I got a message regarding the ID key.

    While I'm not directly looking for help on this particular issue, just wanted to know if there's a list of errors codes and messages I can get when using different eWare objects or at least some hints to deal with these kind of issues.

    Thanks much


    Error received is:

    eWare.eWareBlockContainer error '8000ffff'

    SetIdentityColumn failed



  • I answer myself in the error side, it was caused by a misconfiguration on CRM, once I corrected it works fine. I keep answering how to get info on detail on errors. Thanks!

  • Hi Francisco. I got a same problem. Could you tell me what kind of misconfiguration was ?

    Thank you.

  • Hi Jenny,

    To obtain more detailed ASP errors it is good practice to do the following:

    Within your IE browser Tools/Internet Options menu, and on the advanced tab, uncheck "Show friendly HTTP error messages."

    Hit Apply, OK, and refresh the page in question.

    Within IIS Manager, navigate to the CRM installation's virtual directory.

    Right click select properties and from the Virtual Directory tab hit configuration.

    Under Configuration - debugging tab, enable asp client side script debugging

    Restart IIS and try to load the page again, this time you should see a more detailed error message

    In the case of this error it would be useful for you to check the SQL Log, it sounds like the misconfiguration could relate to field size for the new entity fields.

    If you find errors within the SQL log maybe post them to here and we can investigate further



  • Thank you Elaine.

    I set all debugging instruction that you advised me and I ran it again.

    The error message is still same.

    "eWare.eWareBlockContainer error '8000ffff' SetIdentityColumn failed"

    Here are my detail scenario that I did.

    1. I created new table for customer survey on Self-Service website.

    2. Created Screen and block.

    3. Get block on self-service website

    4. click "Save" : excute block ==> then I get the above error message.

    When I created a table, CRM created Primary Key(surveyID) automatically and I changed property of PK that is increased by 1 using Identity feature.

    In this case, do I still need to input that PK manually ?  I guess because of this PK the error message is occurred. This is the 1st time to create table on CRM and add a feature on self-service.

    If I look at the system log on CRM the error mssage is only "Entering SetIdentityColumn Critical Section for Cust_Survey ' as there is no specific error message on SQL Log.

    If you have any idea about this, could you give me any suggestions ? I appreciate for it very much.

  • Hi Jenny

    You should change the column back to not auto increment. Crm should handle the setting of the id.

    The auto increment id field is causing the problem

    If you are inserting into the table using blocks etc then it will try to generate the id itself hence the error

    The tables in self service are created and managed by CRM must be managed by CRM objects.  

    The record object used by the Sage CRM blocks will take off the increment.

    I hope this helps


  • Jenny, in my case I went to my new entity definition at Advanced Personalization, tables and databases, then edited the table definition, there's a field for the ID I had left blank, corrected and worked fine.

  • Hi Jenny,

    You could find the solution for the above mentioned issue in my latest post.

    Step by Step Solution: Fixing SetIdentityColumn failed error

    Hope that will help you.




     "Anyone who has never made a mistake has never tried anything new."

  • As Fransisco said there is no need to code or use SQL.  Please see