Entity Field Search SQL character Limitation

This question is not answered

When entering Search SQL for a field I discovered there is a character limitation. in the database the table in question is the Custom_Edits table and the column is Colp_SearchSQL this has a limitation of 128 characters, but the screen in the application is actually less, major pain in the butt surrounding this.

All Replies
  • Thanks for the comment.

    I'll pass this on to my colleagues.  Were you able to able to work around the issue.


  • Once again my savior is Mr. Jeff Richards. My situation was able to be worked around, but only because I was being dumb with my SQL statement, and I was able to re-write using less characters. However, the issue still applies only because if I continue in the path I am going (based on company needs) this will become an issue again in the future.

    I appreciate you escalating this. I just wanted to point out the fact once again that while the Custom_Edits table field allows for 128 characters (which is very low), when you are actually in the application it doesn't allow you to enter more than a lower number of characters compared to the 128 character limit in the database. I appreciate all of this Mr. Richards!

  • Easiest way to work around this is to set the Search SQL in the Create Script of the ASS field.

    SearchSQL = 'select x from y';

    This option also allows you to do dynamic search SQL based on other fields/data in the DB.

    Sage CRM specialist and all round fan! Please feel free to follow me on twitter @dannycrm