Hi - we are encountering a problem with email manager and hoping someone can help!

The email manager service keeps going into a suspended mode.  The service is still running but nothing processes - it just keeps repeating the sleep period message.  Here is a snippet of the log:

2019-04-04 11:24:21.426> Suspending service as DeleteMessage call failed with error Max line length exceeded.
2019-04-04 11:24:21.830> Mailbox: crm@xxx.com
2019-04-04 11:24:21.832> About to disconnect from mail server.
2019-04-04 11:24:21.928> Mailbox: crm@xxx.com
2019-04-04 11:24:22.171> Disconnected to mail server.
2019-04-04 11:24:22.335> **************************finished job run.**************************
2019-04-04 11:24:22.336> Sleep Period = 30 seconds
2019-04-04 11:24:53.353> **************End of wait**************
2019-04-04 11:24:53.354> mail service count 1
2019-04-04 11:24:53.356> **************************finished job run.**************************
2019-04-04 11:24:53.357> Sleep Period = 120 seconds
2019-04-04 11:26:54.425> **************End of wait**************
2019-04-04 11:26:54.426> mail service count 1
2019-04-04 11:26:54.427> **************************finished job run.**************************
2019-04-04 11:26:54.429> Sleep Period = 120 seconds
2019-04-04 11:28:55.507> **************End of wait**************
2019-04-04 11:28:55.509> mail service count 1
2019-04-04 11:28:55.511> **************************finished job run.**************************
2019-04-04 11:28:55.513> Sleep Period = 120 seconds
2019-04-04 11:30:56.602> **************End of wait**************
2019-04-04 11:30:56.603> mail service count 1
2019-04-04 11:30:56.605> **************************finished job run.**************************
2019-04-04 11:30:56.606> Sleep Period = 120 seconds
2019-04-04 11:32:57.685> **************End of wait**************
2019-04-04 11:32:57.686> mail service count 1
2019-04-04 11:32:57.687> **************************finished job run.**************************
2019-04-04 11:32:57.689> Sleep Period = 120 seconds
2019-04-04 11:34:58.781> **************End of wait**************
2019-04-04 11:34:58.782> mail service count 1
2019-04-04 11:34:58.784> **************************finished job run.**************************
2019-04-04 11:34:58.785> Sleep Period = 120 seconds
2019-04-04 11:36:59.865> **************End of wait**************
2019-04-04 11:36:59.867> mail service count 1
2019-04-04 11:36:59.868> **************************finished job run.**************************
2019-04-04 11:36:59.869> Sleep Period = 120 seconds
2019-04-04 11:39:00.941> **************End of wait**************
2019-04-04 11:39:00.942> mail service count 1
2019-04-04 11:39:00.943> **************************finished job run.**************************
2019-04-04 11:39:00.945> Sleep Period = 120 seconds

Anyone had this issue before?  Any help much appreciated.