Aissigned To and Team Fields

  • I am trying to automatically populate the ‘Assigned to’ and ‘Team’ field when creating an opportunity. The field setting are set with the relevant defaults when I look at them through the customization then fields tab but they do not auto populate Can anyone help?

  • What version of CRM, up to the patch level are you running?[you can check that on the CRM login page] Below works OK on my side, in that the New Opportunity defaults to the correct User/Team.

    -Under Admin|Customisation|Opportunity|edit the 'Assigned To' [oppo_assigneduserid] field. Change 'Default' to e.g. the 'Current User'

    -Do the same for the 'Team ' [oppo_channelid] field, you can change that to 'Current Users Default Team'

    You might confirm the version + patch level you are on, and I will try to see can I reproduce the problem on the same version as you.

    Pat Dolan

    Senior Support Engineer, Sage CRM | Sage CRM Solutions

  • Pat

    Pat

    Thanks for that, I have already check the setting you mention and it is not working.

    We are running a linked system. The current version is 6.2.d Do we need a patch?

  • Thanks Andrew - I will check this out on v6.2e and v6.1o - the latest patches for those releases and will see if there is a bug there. These should work as above, as per the steps in the previous post  - so I'll do some more digging on this side and will report back to you.

    Pat Dolan

    Senior Support Engineer, Sage CRM | Sage CRM Solutions

  • I think this is a workflow question.  If you are creating an opportunity, my guess is that you are using the default Opportunity Workflow. Go to Administration>Advanced Customization>Workflow.  Use the Admin Guide to help help, but look at the Workflow Actions of the primary rule 'New Opportunity'.


  • You're on the right path here alright Jeff.

    If a field is shown as part of a workflow action, then the default is taken from the setting on the workflow action and not from the field level default. This is so that the workflow is not resetting the oppo assigned user to the current user everytime you flow through the opportunity. So, this is not a bug but by design. Some CreateScript is often used to set the default values.  

    Below should fix this issue, Andrew, you might try this:

    [1] Setting the Oppo_Assigned UserId default:

    Go to administration | advanced customisation | workflow & edit the 'Opportunity Workflow'

    Then edit the oppo_assignedto Workflow Action.

    Set the following:

    Type=Set Column Value

    column=oppo_assigneduserid

    Value=#user_userid#

    That sets the default on the Oppo_Assigned to Column.

    [2] For the Team default, in the Opportunity Workflow select oppo_channelid this time.

    Type=Set Column Value

    column=oppo_assigneduserid

    [you can leave Value blank]

    But this time add the following under the CreateScript area:

    DefaultValue=CurrentUser.user_primarychannelid;

    Save it.

    Pat Dolan

    Senior Support Engineer, Sage CRM | Sage CRM Solutions

  • Thanks for that. All working now and the boss is happy