"Invalid TLV record" when running any Crystal report in CRM7.0 after installing SP1 and patch D

  • Hi everybody,

    I installed SP1 and Patch D yesterday and none of my crystal reports are working in CRM now. They run fine in Crystal reports. All the reports created in CRM are working ok.

    Those reports were working fine before the update.

    I did an IISRESET; stopped and restarted all the CRM services; Remapped the database and tables in Crystal Reports; I even created a brand new report and tried to run it in CRM and I get the same error. So it must be something to do with the viewer.

    My CRM server is a server 2003 sp2.

    I get the following error message:

    Error Occurred creating Report Object: Invalid TLV record.ReportName: c:\program files\sage\crm\crm\wwwroot\reports\AsymaReports\Age Opportunity Forecast.rpt

    Anybody has seen this?

    Any help will be appreciated. Thanks!

     

  • Hi  Prabha,

     

    Have you check the Documents and Reports configuration settings in the Sage CRM. To check the same follow the below instructions. 

     

    1.     Navigate to the AdministrationàEmail and DocumentsàDocuments and Reports configuration.

    2.     Check the path set in Root Directory for reports field. ( C:\Program Files\Sage\CRM\<CRMInstanceName>\WWWRoot\Reports\ )

    3.     Now, do the Metadata Refresh; to do the same please navigate to Administration --> System --> Metadata.

    4.     Select the Refresh All and click on the Execute Refresh button.

    5.     Log off from the CRM system.

    6.     Run the IISRESET command

    7.     Login to the Sage CRM system

     

    Hope this helps!

     

    Sincerely,

    Dinesh

    ----------------------------------------------------------------------------------------
    Greytrix
    It's time to think outside the box.

    GUMUTM: Migration and Integration solutions for Sage CRM,
    Sage SalesLogix,
    Sage CRM.com, ACT!, Sage Accpac, Sage Pro, Sage MAS 90/200/500 ERP.

    Greytrix : facebook | twitter | LinkedIn
    blogs: CRM : http://sagecrmaddons.blogspot.com | MAS : http://sagemas.blogspot.com/
    E-mail: crm@greytrix.com   |  web: www.greytrix.com  |  Support : Live Help

    ………………………………………………………………………………………………………………………………… 

    --------------------------------------------------------------------------------------------------------------------------------------
    New Release - Sage CRM for Sage ERP X3 - real-time, bi-directional, anywhere access.
    Celebrating 900+ Sage CRM Posts
    - http://www.greytrix.com/blogs/sagecrm/
    Sage Premier Gold Development Partner - Sage X3, Sage 100/300/500/Pro ERP & Sage CRM
    *Sage CRM Gold Development Partner of the Year 2004 and 2011*
    E-mail: crm@greytrix.com |  Twitter: greytrix

  • The report directory is right; i did the metadata update and IISRESET. I was talking to a Sage CRM technician at ACCPAC and i created a brand new report from the Company table in Crystal reports 11 with a couple of fields and sent it to him; he got the exact same error message on his CRM 7.0 SP1

    I cannot even go back to the program before SP1 was installed because i get a different error message.

  • Hi Prabha,

    The TLV error is a Crystal Reports error. Are you able to run the report in Crystal without issue ?

    If you see the issue within Crystal independently of Sage CRM then check the steps below

    1.Ensure the crystal report versions match. (i.e., the version in which the report has been created has to match the version at the client's workstation.)

    2.If the versions are the same and you still get the error, it could be due to a "copy paste mismatch". Try copying the .rpt file in a different location and then running it.

    3.This error comes up more in the case of custom reports and due to file type / path mismatch. Try pasting the file through a .zip / .rar format and then unzip it to the desired location.

    4.If this does not solve the problem, check for the presence of important dll files in the client computer.

    5.Another associated error message (due to copy paste mismatch) will be "Dos error".

    6.Verify all dependencies of craxdrt.dll have been installed and registered. (Use dependency walker and/or .dep file)

    7.If the viewer is reading a file saved with data, check the file length. If it happens to be of zero bytes, then delete the file.

    If you only see this error within Sage CRM please check and confirm the viewer version you are using

    If there is a mismatch between the crystal reports version the report was created in and the viewer version you will see this type of error

    Thanks

    Elaine

  • The reports run fine in Crystal. In fact I had to go modify the reports so I could run them in Crystal for our staff meeting because they are KPI reports for our organization.

    Is there a newer version of the Crystal Viewer that I need to download and run? As I said those reports were running fine in CRM 7.0. The problem started when I installed SP1 and patch D for CRM 7.0

  • Hi Prabha

    If you're using Crystal 11 then you should be using Crystal Report Viewer XI too

    Please check that this is what you have set under

    Administration -> E-mail and Documents -> Documents & Reports Configuration

    Crystal Reports Viewer

    Are there any errors within the Sage CRM logs ?

    Thanks

    Elaine

  • Hi Elaine,

    The viewer says: \crystalreportviewers11

    I wish somebody could take a look at the RunReport.asp file and debug it. There is something else:

    In the Reports folder there are 2 folders: "CrystalReportsViewer" and "CrystalReportViewer" each with the same 3 files but different versions. The "CrystalReportsViewer" files are dated 2008 and the the other one are 2010. I did a test and renamed the RunReport.asp file in the "CrystalReportViewer" folder and copied the other one in there. When I run the report i get a different error: "Error Occurred Reading Records: Logon failed. Details: [Database Vendor Code: 18456 ]" meaning may be (?)that it is using the RunReport.asp from this folder.

    There is nothing pertaining to running the report in the log files.

    I don't know if this will help further into troubleshooting.

    Let me know what you guys think.

     

     

     

     

  • Hi Prabha,

    I will take a look at this next week, I'm out of the office tomorrow

    Thanks

  • Thanks. Just an FYI though, Sage CRM techs have told me to go buy Crystal Reports Server 11.0 @ more than $2600(full blown version) + a more than $500 yearly maintenance fee. I had the Web reporting by Crystal DVD provided by Sage and they said it was a stripped down version and CRM 7.0 needed the full blown version. They informed me that the SP1 of CRM 7.0 requires that and CRM 7.0 did not. I am not sure of the logic of this.

  • Just an update. I removed all my crystal reports (all of them: report server, crystal reports 11, enterprise) from the server and installed Crystal Reports 11 SP2 developer. No resolution.

    I then opened the RunReport.asp found in the CrystalReportViewer folder in WWWRoot\Reports and compared it to the version before the upgrade and I changed a line:

    Set session("oApp") = Server.CreateObject("CrystalRunTime.Application.1") to Set session("oApp") = Server.CreateObject("CrystalRunTime.Application.11")

    Now all the crystal reports run fine on the server BUT none of them run on the workstations. I now get this error:

    Error Occurred creating Report Object: Access denied. Details: errorReportName: c:\program files\sage\crm\crm\wwwroot\reports\AsymaReports

    So my question is: why is it looking on c:\ when it is from the workstations? Shouldn't it be the server name or ip address of the server? It runs on the server because the path is right for the server but a workstation cannot see the c drive of the server.

    Any ideas? Thanks.

  • So guess what?  I clicked on compatibility view and now the reports work on my workstation. Go figure!

  • Hi Prabha,

    That's good news and a handy tip

    Thanks for letting us know

  • Hi Prabha,

    I have the same problem with you. Just wondering, what "compatibility View" that you clicked?

    Where can I find it?

    Thanks

    David

    Regards,

    David Chandra

  • Hi David,

    It is the compatibility view on your internet browser. I run IE 8 so it is in Tools - compatibility view. Now that was the last thing I did after I did all of the above. So I don't know if it is that that fixed it or a combination of all that I did. Hope that helps.