Error Loading Data: add 'List' gadget to Interactive Dashboard

  • All Hail the Herbalists! Greetings and salutations.

    I have created a lovely new Interactive Dashboard and I want to add a Company table 'List' gadget to it. When I select the Company table at Step 1 of 5 and click Next, I get the error 'Error loading data'.

    Trying to add a Company table List gadget to the Interactive Dashboard called 'Newtown Real Estate Agents'

    I have read some of the forum posts on this and I have done the following:

    • Disabled ESC in IE on the CRM server  – this is disabled
    • Ensured that Web Service Extensions are enabled for ASP and CRM – all are enabled except the 32-bit ASP ones. Tested enabling the 32-bit ASP ones to no effect
    • Also in ASP checked that Enable Parent Paths is set to True – Enable Parent Paths is set to True
    • CRM server is up to date with Windows Updates as of 28/6/12

    The server is running Windows Server 2008 R2 Enterprise Service Pack 1. This O/S is 64-bit. The database is SQL Server 2008 R2. Sage CRM is 7.1 SP2.

    The out-of-the-box Company dashboard works fine. I have created another dashboard which works fine but it only uses template gadgets, not custom gadgets . And I can add a template such ‘My Calendar’ to the 'Newtown' dashboard, and that works.

    Can anyone please shed some light on this problem? All responses will be greatly appreciated.

    Cheers,
    HB 

  • Hi,

     

    If you are getting the error message “The Dashboard has experienced a problem. Please contact your System Administrator.” on clicking the Dashboard tab then the below activity will not work as the Tomcat Server is not properly installed/configured. You can check the suggestions given in our blog to make it up and running. Here is the link.

     

    http://www.greytrix.com/blogs/sagecrm/2012/06/26/error-exporting-reports-to-excel-in-crm-part-2/

     

    Hope this helps!

     

    Regards,

    Dinesh

    --------------------------------------------------------------------------------------------------------------------------------------
    New Release - Sage CRM for Sage ERP X3 - real-time, bi-directional, anywhere access.
    Celebrating 900+ Sage CRM Posts
    - http://www.greytrix.com/blogs/sagecrm/
    Sage Premier Gold Development Partner - Sage X3, Sage 100/300/500/Pro ERP & Sage CRM
    *Sage CRM Gold Development Partner of the Year 2004 and 2011*
    E-mail: crm@greytrix.com |  Twitter: greytrix

  • Thanks Dinesh, but the error is 'Error loading data' when I try to add a List gadget to the ID. It is the adding of the gadget that is failing.

     

    Cheers,
    HB

  • HB

    Can you test this please

    In your browser enter the following

    http://[servername]/sdata/[installname]j/sagecrm/-/$schema

    so if your server is called 'Fred' and your CRM install is called 'Jane' then you would enter

    http://fred/sdata/janej/sagecrm/-/$schema

    The extra 'j' is important.  If you enter that do you get 404 error?  I am just wondering if your dashboard has a problem making a request and whether it is being redirected correctly.

    The next step is to look at the redirector itself. There's a default test page in the sdata application which can be used for this. The URL is as follows:

    http://servername/sdata/test.html

    This should redirect to http://[servername]/sdata/Default.aspx?r=/sdata/test.html. Both URLs should give the same test page.


  • Thanks Jeff. I loaded both URLs and got positive results for both. The first did not load a 404 error. I looks like this:

     

     

    The second URL loaded the test page that you spoke about. To wit:

     

     

    If these are the expected results, what is the next step in resolving this problem?

    Cheers,
    HB 

     

  • HB

    Hmmmmm.... then that shows Sdata and the Interactive Dashboard should be working.

    Were you trying to create the Interactive Dashboard as the System Admin user?

    I suspect that some of the config inormation or the settings used to redirect the dashboard are wrong but I don't know as yet what they would be.  I assume you have logged a case?


  • I like the 'Hmmmmmmmm.....'. I can almost see you rubbing your chin.

    I am creating the gadget as Sys Admin. I have raised the issue with our Sage CRM supplier and they have said they will escalate through the approriate channels.

    Cheers,
    HB 

  • Hello,

    was there a resolution to this issue.  I appear to have the same issue on my test test system.

    thanks much

    mark

  • My issue is similar (same server setup as above) and though I have a Sage support ticket, I don't believe there's a known fix to what might need adjusting. We've tried url rewrites, IE ESC, new java, old java, (back to 6.27 ;-) localhost changes, tested sdata, crmj, - given named local admin to Tomcat services, ASP, Authentication...

    In my case, it occurred going from 7.1c to service pack 2. The Welcome dashboard and our customized dashboards still work without issue and they can contain company list gadgets - it's only the Company > Dashboard tab that will load with errors and won't allow even Admin to add or save any new company list gadgets.

    I am able to create a dashboard copy, but I get the error above when I attempt to save any list gadgets //same result for a new dashboard for company// but only within the context of Company > Dashboard tab.

    Right now the workaround is to hide the tab to all but Admin user and point users to the Summary Tab and to use the Quick Look tab.

    As a side note: the other items that do not function for us, post-upgrade, is the calendar icon //it doesn't appear// under tasks and we're still battling why some remote users are unable to export reports to csv or Excel.  Good luck! I'll be sure to post if a fix comes my way.

  • Hi erica

    i read your above post and i face the same problem your talk about ,i would tell that i solve the the import reports to excel in undirect way ,,,,just do the following

    1-reinstall the crm (when you have to chose the setup type)select  (change existing install) of crm then select (IIS Aliases) then complete to the end

    .the system will back to 7.1 i reinstall SP2

    if tis still does not work do the following

    2-install (url writer ) from

    www.microsoft.com/.../install.aspx

    then

    go to

    C:\Program Files (x86)\Sage\CRM\Services\IISUtils remove the old one and the new,,,,,

    finally:

    just make sure that the tomcat & World Wide Web Publishing Services is running ok

  • *C:\Program Files (x86)\Sage\CRM\Services\IISUtils remove the old one and the new,,,,,

    i mean remove the old URL and put the new

  • Jeff,

    when i load the sata test page io get a 404.

    Server Error in Application "DEFAULT WEB SITE/SDATA"

    Internet Information Services 7.5

    Error Summary

    HTTP Error 404.0 - Not Found

    The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

    Detailed Error Information

    Module IIS Web Core

    Notification MapRequestHandler

    Handler StaticFile

    Error Code 0x80070002

    Requested URL http://sdsfs:80/sdata/test.htm

    Physical Path C:\Sage\CRM\Services\IISUtils\CRMRewriter\test.htm

    Logon Method Anonymous

    Logon User Anonymous

    Most likely causes:

    The directory or file specified does not exist on the Web server.

    The URL contains a typographical error.

    A custom filter or module, such as URLScan, restricts access to the file.

    Things you can try:

    Create the content on the Web server.

    Review the browser URL.

    Create a tracing rule to track failed requests for this HTTP status code and see which module is calling SetStatus. For more information about creating a tracing rule for failed requests, click here.

    Links and More Information

    This error means that the file or directory does not exist on the server. Create the file or directory and try the request again.

    View more information ยป

    Thoughts on what i am missing here?

    When i look into that physical directory i do not have the test.htm file

    However when i use this link

    http://[servername]/sdata/default.aspx?r=/sdata/test.html

    I get a keep alive page with the below

    Headers

    Key Value

    Connection keep-alive

    Accept text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8

    Accept-Encoding gzip, deflate, sdch

    Accept-Language en-US,en;q=0.8

    Cookie ASPSESSIONIDQQTBBQSB=BGEDNBIDBEALNFGELPDMCLHK

    Host sdsfs

    User-Agent Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

    Upgrade-Insecure-Requests 1

    DNT 1

    X-Rewrite-Url /sdata/default.aspx?r=/sdata/test.html

    Server Variables

    Key Value

    ALL_HTTP HTTP_CONNECTION:keep-alive HTTP_ACCEPT:text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 HTTP_ACCEPT_ENCODING:gzip, deflate, sdch HTTP_ACCEPT_LANGUAGE:en-US,en;q=0.8 HTTP_COOKIE:ASPSESSIONIDQQTBBQSB=BGEDNBIDBEALNFGELPDMCLHK HTTP_HOST:sdsfs HTTP_USER_AGENT:Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36 HTTP_UPGRADE_INSECURE_REQUESTS:1 HTTP_DNT:1

    ALL_RAW Connection: keep-alive Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 Accept-Encoding: gzip, deflate, sdch Accept-Language: en-US,en;q=0.8 Cookie: ASPSESSIONIDQQTBBQSB=BGEDNBIDBEALNFGELPDMCLHK Host: sdsfs User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36 Upgrade-Insecure-Requests: 1 DNT: 1

    APPL_MD_PATH /LM/W3SVC/1/ROOT/sdata

    APPL_PHYSICAL_PATH C:\Sage\CRM\Services\IISUtils\CRMRewriter\

    AUTH_TYPE

    AUTH_USER

    AUTH_PASSWORD

    LOGON_USER

    REMOTE_USER

    CERT_COOKIE

    CERT_FLAGS

    CERT_ISSUER

    CERT_KEYSIZE

    CERT_SECRETKEYSIZE

    CERT_SERIALNUMBER

    CERT_SERVER_ISSUER

    CERT_SERVER_SUBJECT

    CERT_SUBJECT

    CONTENT_LENGTH 0

    CONTENT_TYPE

    GATEWAY_INTERFACE CGI/1.1

    HTTPS off

    HTTPS_KEYSIZE

    HTTPS_SECRETKEYSIZE

    HTTPS_SERVER_ISSUER

    HTTPS_SERVER_SUBJECT

    INSTANCE_ID 1

    INSTANCE_META_PATH /LM/W3SVC/1

    LOCAL_ADDR 192.168.42.1

    PATH_INFO /sdata/default.aspx

    PATH_TRANSLATED C:\Sage\CRM\Services\IISUtils\CRMRewriter\default.aspx

    QUERY_STRING r=/sdata/test.html

    REMOTE_ADDR 192.168.42.2

    REMOTE_HOST 192.168.42.2

    REMOTE_PORT 63147

    REQUEST_METHOD GET

    SCRIPT_NAME /sdata/default.aspx

    SERVER_NAME sdsfs

    SERVER_PORT 80

    SERVER_PORT_SECURE 0

    SERVER_PROTOCOL HTTP/1.1

    SERVER_SOFTWARE Microsoft-IIS/7.5

    URL /sdata/default.aspx

    HTTP_CONNECTION keep-alive

    HTTP_ACCEPT text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8

    HTTP_ACCEPT_ENCODING gzip, deflate, sdch

    HTTP_ACCEPT_LANGUAGE en-US,en;q=0.8

    HTTP_COOKIE ASPSESSIONIDQQTBBQSB=BGEDNBIDBEALNFGELPDMCLHK

    HTTP_HOST sdsfs

    HTTP_USER_AGENT Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

    HTTP_UPGRADE_INSECURE_REQUESTS 1

    HTTP_DNT 1

    HTTP_X_REWRITE_URL /sdata/default.aspx?r=/sdata/test.html

    Query String

    Key Value

    r /sdata/test.html

    Form

    Key Value

    regards

    Josh

  • Jeff,

    Does this mean that my redirector is not working? I think it does. Is there a way to reset this up, or reconfigure it to work correctly ?

    Thanks again

    Regards

    Josh

  • Sorry,

    also further to this when i use the address you provided http://sdsfs/sdata/crmj/sagecrm/-/$schema

    I just get a blank page.

    Josh

  • Josh

    Getting a 'blank' $schema response is quite usual if you used Chrome see below

    But if you right click and 'view page source' you will be able to check whether the feed is actually working.  If there was a problem I would expect an error to be returned.